OpenRoads Designer CONNECT Edition SDK Help

CreateTangentToLineAndCircleRadius Method

Creates Tangent Line when given Spiral, Thrupoint, and Radius

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  CircularArc[]CreateTangentToLineAndCircleRadius( Line backElement, CircularArc aheadElement,double radius,double tolerance)

Parameters

SettingDescription
  Line Lline used as reference
  CircularArc Circle line used as reference
   Thru point of the arc
   tolerance of the mathematics

Return Value

CircularArc[]

See Also